FAQ

Frequently Asked Questions (FAQ)

Home > Support > FAQ > Web Service

FAQ - Web Service

/

Some of my addresses were not geocoded. What is the reason?

There are a number of possible reasons, why an address was not geocoded. They are written into the field OUT_GEOStatus. Possible values are:
0:    Geo coordinates are not provided, because you have no more
       geocoding transactions left.
1:    Geo coordinates are not provided, because geo coding is not
       available for this country.
2:    Geo coordinates are not provided, because the Validation Status
       was not V or C.
3:    Geo coordinates are not provided, because geo coding
       reported a no match.
4:    Geo coordinates are provided. The field OUT_GEOAccuracy
       describes the accuracy of the coordinates.

How do I import my processed data into Microsoft Excel®?

Start Excel.
Now select in the "Data" menu the option "Import External Data".

Select the file type of the file you want to import: "Text Files (*.txt;*.csv;*.tab;*.asc)".
Select the file you want to import.

Continue with "Import".

In the next step, select how the fields of your file are separated.Usually the software automatically detects the format and suggests the correct separator, in this example "Delimited".

Continue with "Next".

In the next step, state the field delimiter and the text qualifier.Here in the example we select as field delimiter "Comma" and as Text Qualifier quotation mark "{none}".

Continue with "Next".

In the next step you have the option to rename fields and to change data types.Set the field, which contains only numbers (e.g. ID or cluster sizes) to an appropriate data type, e.g. integer or double.Please note: Never set the data type of fields which contain postal codes to number! This would remove the leading 0-characters. The postal code 01438 would become 1438. This field, as the "OUT_PostalCode" field, should be declared as text.

Confirm your settings with "Next".

In the last step, select if you want to create a new worksheet or if you want to add the data to an existing worksheet.Click on "OK" to complete the export.

How long does it take for my data to be processed?

The AddressDoctor Data Quality Center analyses your address data immediately after the file upload is completed. After the analysis, you will receive an email with instructions on how to confirm the job and start the processing. As soon as the Link contained in the e-mail has been clicked, the processing will start. Smaller files of less than 100.000 records are often finished in less than one hour. Larger files, especially those containing additional services, might take longer. However, in most cases these files will be ready within 24 hours. After processing is finished, you will receive an email with download Instructions.

Is it possible to upload my file via FTP?

No, at this time only the browser-based upload is available.

Which file formats can be processed in the DQC?

The DQC can currently process text files with separators and delimiters. Text files with fixed field length or other file formats, for instance Excel, have to be converted before upload.

I would like to have a change of address check (NCOA) performed on my address data. How can I do that?

NCOA processing is available in the AddressDoctor DQC. Please create an account if you do not already have one and fill out the required statement regarding the ownership of the address file. Once you have sent this agreement to our contracts department, the NCOA will be enabled for your DQC account. NCOA is available for Austria, Germany, and Switzerland.

I selected the country-specific Casing and English locality name in the DQC for German addresses. Why do I receive the corrected addresses in capital letters only, although the data records should actually be present in upper and lower case?

So that umlauts or other special characters can be converted into the English language, the transliteration algorithm is automatically called in the background. This requires the return of capital letters only.

What happens to non-assigned input fields?

The DQC output file contains all input fields, regardless if they were assigned or not. Following those are the output fields, which start with "OUT_". Non-assigned fields are not considered for address verification.

How long does AddressDoctor save data that has been uploaded in the AddressDoctor DQC?

When the time indicated below has elapsed, the input file (file that the user has uploaded), the corresponding processed data in the database and, if still available, the result file, and the report are deleted.

 

  • Deleted, non-confirmed orders or orders with processing errors: 30 days
  • Orders with generated Audit Report, but not yet downloaded: 180 days
  • Downloaded Orders: 270 days
How do I export my data from Microsoft Access in order to process them in the DQC?

Start Access and open the file, through the menu "File" -> "Open" or double-click on the Access file. Now you should see a picture similar to this:

Now click the right mouse button on the table which you want to export and select "Export" in the context menu.

In the next step, select the file type of the exported data. Select here "Text Files (*.txt;*.csv;*.tab;*.asc)". You can enter any name or, as in the example, keep the name which is suggested by the export wizard.

Continue with "Export".

In the export wizard you can set the properties of the CSV file. Select "Delimited".

Select "Advanced" to specify more detailed settings.

Code Page "Unicode UTF-8" is selected here in order to maintain the Japanese characters.

Confirm your settings with "OK".

Select as field delimiter "Semicolon" and as Text Qualifier quotation mark """. It's often helpful to select "Include Field Names on First Row".

Continue with "Next".

Click on "Finish" to complete the export.

When you open the exported file in an editor, it should have the following format:

How do I export my data from Microsoft Excel® in order to process them in the DQC?

Start Excel® and open the Excel® file, through the menu "File" -> "Open"or double-click on the Excel® file.

Now you should see a picture similar to this:

Now select from the "File" menu the option "Save As".

In the next step, select the file type of the exported data.

Select "CSV (Comma delimited) (*.csv)".

Continue with "Save".

When you open the exported file in an editor, it should have the following format:

Please note that you might have to change your "List separator" in Windows from comma to semicolon to obtain the same result - this isstrongly recommended as your data might well contain commas inside the actual Excel columns:

  1. Click the Windows Start menu.
  2. Click Control Panel.
  3. Open the Regional and Language Options dialog box.
  4. Click the Regional Options Tab.
  5. Click Customize.
  6. Type a new separator in the List separator box.
  7. Click OK twice.

You can also select as file type "Text (Tab delimited) (*.txt)" instead of CSV.

When you open the exported file in an editor, it should have the following format:

For comparison, the two output files, formatted from Excel® by default:

CSV, semicolon delimited:

TXT, tab delimited:

How do I import my processed data into Microsoft Access?

Start Access.

Create a new Database.

Click the right mouse button in the blank space and select "Import" from the context menu.

Select the file type of the file you want to import: "Text Files (*.txt;*.csv;*.tab;*.asc)". Select the file you want to import.

Continue with "Import".

In the next step, select how the fields of your file are separated.Usually, the software automatically detects the format and suggests the correct separator, in this example "Delimited".

Continue with "Next".

If the file contains characters which can't be displayed in the default selected encoding, select "Advanced"to specify more detailed settings.

In this example Code Page "Unicode (UTF-8)" is selected.

Confirm your settings with "OK".

The preview is adjusted instantly: Here you can see the Japanese characters.

Continue with "Next".

In the next step, state the field delimiter and the text qualifier.Here in the example we select as field delimiter "Semicolon" and as Text Qualifier quotation mark """.

If the file contains the field names in the first row, select "First Row Contains Field Names".

Continue with "Next".

Next you can select if you want to create a new table or if you want to add the data to an existing table.Here in this example we create a new table. Since we created a new database in the beginning, there isn't a table to which we can add the data.


Continue with "Next".

In the next step you have the option to rename fields and to change data types.Set the field, which contains only numbers (e.g. ID or cluster sizes) to an appropriate data type, e.g. integer or double.Plase note: Never set the data type of fields which contain postal codes to number! This would remove the leading 0-characters. The postal code 01438 would become 1438. This field, just as the "OUT_PostalCode" field, should be declared as text.

Confirm your settings with "Next".

In the next step you can set the primary key.

This is only necessary if the data sets are not numbered.

Continue with "Next".

In the last step you have to enter the name of the new table.

Click on "Finish" to complete the export.

How can I calculate the distance between two geo-coordinates?
Calculation of a distance between two geographical points in WGS84

It is very complicated to calculate the exact distance between two geographical coordinates since different projections as well as the oblateness of the earth has to be considered. But in most cases a simple formula will help as long as the distance is not too small and the points are not too close to the poles.

You will need WGS84 geo-coordinates in decimal degree (not in degree-minutes-seconds like N 49° 29.296 E 008° 27.722). All geo-coordinates provided by AdressDoctor are in decimal degree.

At first your geo-coordinates need to be transformed into a radian measure. To do this simply multiply the latitudes and longitudes by ?/180 or use in Excel =radiant(X) and =radiant(Y).

You will get the approximate air-line distance with following formula:

d = R * arccos(sin(X2) * sin(X1) + cos(X2) * cos(X1) * cos(Y2 – Y1))

Earth radius R = 6378 k

Example:

Lisbon, Portugal:

x-coord: 9.136523757581143
y-coord: 38.744916875859985

Arnheim, Netherlands:

x-coord: 5.962115675929862
y-coord: 51.98395045710915

Longitude/Latidude

Decimal Degree

Radiant

X1

9.136523757581

0.15946242

Y1

38.744916875860

0.67622637

X2

5.962115675930

0.10405855

Y2

51.983950457109

0.907291

Distance:

d = R * arccos(sin(X2) * sin(X1) + cos(X2) * cos(X1) * cos(Y2 – Y1))
d = R * arccos(sin(0.10405855) * sin(0.15946242) + cos(0.10405855) * cos(0.15946242) * cos(0.90729109 – 0.67622637))
d = 1503 km

What is the meaning of the field OUT_GEOAccuracy?

The field OUT_GEOAccuracy describes the accuracy of the coordinates.

To what detail level are addresses geocoded?

Where possible, addresses are geocoded to rooftop level. If this is not possible, they may be geocoded to the street, next fallback is center of a zip code or a locality. The detail level is written to the field OUT_GEOAccuracy. Possible values are:

The address was geocoded

STR

The Center of the street was geocoded

ZIPCD

The Center of a suburb within the postcode was geocoded

ZIPC

The Center of the locality within the postcode was geocoded

ZIP

The Center of the postcode was geocoded

What is the meaning of the field OUT_GEOStatus?

The field OUT_GEOStatus describes the possible reasons, why an address was not geocoded. 

Is the geocode set on the middle of the streets or is it offset?

If an address is geocoded to rooftop, it is offset from the center axis of the street.

For what countries does AddressDoctor supply Geocodes?

Please go to Country List and select "Geocoding" to get a current list of all countries supporting Geocoding of addresses.

Are addresses interpolated or referenced exactly to rooftop?

If a geocoded address contains the value ADD in the field OUT_GEOAccuracy, it is an interpolated house number. This means, the exact coordinates for the address are not contained in the reference database. Instead, the position of a street and the range of house numbers of this street are known. Then, the address is interpolated and offset to the proper side of the street.